Home » Support » Knowledge Base » Knowledge Base

Knowledge Base

USB 1.1 Audio and MIDI devices on USB 2.0 ports
Text size [-] [+]

Q: All M-Audio USB devices are currently compliant to the USB 1.1 standard.  Can I use them on a USB 2.0 port?

A: Yes.  If you are running Windows XP, Service Pack 1* needs to be installed in order for the USB 2.0 ports to be downward compatible with USB 1.1 devices.  For Windows 2000, Service Pack 4 is required.  Some Mainboards/Chipsets/USB controllers require the installation of the latest drivers for these components to add full USB 1.1 compatibility.  These drivers are usually available from the mainboard manufacturer's web site.

* Note: Microsoft no longer provides support for Service Pack 1.  You can upgrade your computer, for free, to Windows XP Service Pack 3 (SP3).